Jump to content
bryanc

Slicer question on creating new volume

Recommended Posts

I downloaded Slicer and imported my DICOM file. I have a Visible Human Project CT scan of a pelvis and femurs. My goal is to print the sacrum, both illiums, and both femurs (just the superior halves) as 5 separate pieces. I was following the tutorial on cropping to create a smaller volume, but when I drag the control point down to the image from the blue window, it looks like it's _behind_ the image, and therefore, I can't see where I'm cropping. As an experiment, I tried to crop anyways with a big enough volume that I knew most of the femur would be within the cropped volume, but when I hit the Crop! button, it just displays grey or black space. Not sure what I'm doing incorrectly here.

Share this post


Link to post
Share on other sites

Can you post a screen capture of what you are encountering? Sometimes the crop volume box is displayed in very small size, and it can be difficult to grab the edge manipulators. I wonder if this is the problem you are having.

Share this post


Link to post
Share on other sites

You can see and adjust the cropping box in both the 3D window and in the slices below. In the 3D window, you can left-click and drag anywhere to rotate the volume and box around in 3D to see the adjustable points on each surface. The box always starts out around your whole volume, but you can grab the top dot (light blue) and drag it down.

 

Crop Box.png

CropBox2.png

Share this post


Link to post
Share on other sites

Hey tsehrhardt,

 

I noticed that your bottom panels already have cropping boxes in them. When I used it, my bottom panels did not. According to the tutorial, you're supposed to drag the cropping box from the main "blue" screen down into the image on the bottom panel? Or is this what Dr. Mike is talking about when he says the crop box is just too small?

Share this post


Link to post
Share on other sites

You should not have to drag the crop box from the blue to the bottom--it will appear in all views. I've always had it show up as enclosing the whole volume. Are you able to find your crop box at all? 

Share this post


Link to post
Share on other sites

Ah...I see where things were different: The tutorial on the webpage says to select "all modules" and then "Crop volume" however, you selected "Volume rendering" which then does show me crop box on all panels.

Share this post


Link to post
Share on other sites

Ah ha... ok. So I can get to here. Do I just "Save" this? And if so, there are several options for saving: MRML, NRRD, VP and ACSV. It looks like VolumeProperty is what I want perhaps? Sorry and thanks for walking me through this.

Femur crop b.tiff

Share this post


Link to post
Share on other sites

No problem! :) You need to go to All Modules, then Crop Volume, hit Crop and wait. Then you will see your slice windows change to the area you designated. When you go to Save, you will see that there is a second volume that says "subvolume". This is the cropped volume that you can save as .nrrd. This format can be reopened in Slicer or uploaded to the democratiz3d app to get a printable model.

Share this post


Link to post
Share on other sites

Woot! I _almost_ got what I wanted! Next question: Is there a way for me to just subtract the pelvis? The slice I have is the head of the femur with acetabulum, which when I import into Meshmixer to subtract pelvis, doesn't have an intact head of femur. The CT scan clearly has separation between the femur and the acetabulum, so that surface must exist....

Share this post


Link to post
Share on other sites

Yes, it's uploaded. Unfortunately, there appears to be only one effective shell. (I get 3 objects in Meshmixer, but they all basically highlight the entire object)

Share this post


Link to post
Share on other sites

Hi Bryan,

 

There are a couple of options for you to remove the unwanted bone parts (like the acetabulum) from your models:

 

First, you can upload the subvolume NRRD file you created to democratiz3D and it will convert all the bones in the included volume into STL, including the unwanted portions like the acetabulum in your case. You are correct that they will include both the femoral head and unwanted acetabulum. The unwanted portion can be easily removed in Meshmixer. Open the STL file, use the select tool to select a portion of the unwanted object, and the use Modify->Expand to Connected. This will select everything that is connected to your selection portion, which should be the entire acetabulum. Assuming that the acetabulum is not connected to the femoral head by any mesh, you can then delete the selected mesh and the acetabulum should go away, leaving you with only the desired femoral head.

 

A second, and more difficult approach, will be to manually segment apart the structures in Slicer and then individually export them to STL. This will require you to learn the segmentation module (not that easy). Also, when slicer exports STLs, the output STL files can have multiple mesh defects, something that democratiz3D automatically fixes. You may need to do some additional mesh cleanup after the STL export if you use this method.

 

Terrie, thank you very much for your helpful earlier comments. I am liking all of the prior messages to give you both credit for a stimulating discussion that will surely help many other readers. 
 

Dr. Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×